Resolved
This is resolved now. there was a temporary loss of developer sandboxes due to a misconfiguration in the database of one instance.
Investigating
We are monitoring an incident in which few sandboxes got deleted from an instance incorrectly without properly waiting for the expiry.