Resolved
A fix has been rolled out to all instances
Identified
We've identified an issue where source packages using destructive changes (pre-destructive / post-destructive folders) did not have those components removed during sfp install. Deployments completed successfully; the only effect was that metadata intended for deletion remained in the target org. A fix has been identified and verified, and is being prepared for release. No action is required on your part.