No components marked as affected
Resolved
Fix is now rolling out to all tenants
Identified
When a Salesforce org loses access — for example if its stored refresh token expires, or the connection is revoked — a stale lock can be left on the corresponding environment. Releases and other jobs targeting that environment then queue behind that lock instead of failing, and can stay blocked for up to two hours.
If you see jobs waiting on an environment lock, deactivate the affected environment. That stops new work being dispatched to it and clears the blockage. Reactivate it once the org has been re-authenticated.
A fix is in progress: the lock will be released when the step after acquisition fails, and the wait will be bounded so jobs fail fast rather than queueing indefinitely.